shield Recommended update for fence-agents
SUSE-SLE-HA-12-SP3-2022-557


This update for fence-agents fixes the following issues: - Add upstream PR to aws-vpc-move-ip and apply required resource (jsc#SLE-18202) - ECO: Update fence-agents (jsc#SLE-18227) - Update all scripts to python3 (bsc#1065966) - fence_azure_arm: corrections to support Azure SDK greater then 15 - including backward compatibility (bsc#1185058) - Major upgrade changes:: * fence_kubevirt: new fence agent * configure: dont fail when --with-agents contains virt * fence_mpath: watchdog retries support * fencing: add multi plug support for reboot-action * fencing: fix issue with hardcoded help text length for metadata * fence_lindypdu: new fence agent * fence_openstack: code formatting fixes * Restore port metadata. * Update xml metadata. * Use standard logging. * fence_aws: add filter parameter to be able to limit which nodes are listed * virt: drop pm-fence plugin * virt: drop libvirt-qmf plugin * virt: drop null plugin * virt: drop fence_virtd non-modular build * virt: fix plugin installation regression on upgrades * build: temporary disable -Wcast-align for some agents * fence_virt: metadata fixes, implement manpage generation and metadata/delay/rng checks * virt: drop support for LSB init script * virt: collect docs in one location * spec: use python3 path for newer releases * fence_gce: support google-auth and oauthlib and fallback to deprecated libs when not available * fence_gce: Adds cloud-platform scope for bare metal API and optional proxy flags * fence_redfish: Add diag action * fence_vbox: updated metadata file * fence_vbox: do not flood host account with vboxmanage calls * fence_lpar: Make --managed a required option * fence_zvmip: fix shell-timeout when using new disable-timeout parameter * Adds service account authentication to GCE fence agent * fence_redfish: Fix typo in help. * fence_aws: add support for IMDSv2 * Try to detect directory for initscripts configuration * Add man pages to fence_virtd service file. * fence_virtd: Fix segfault in vl_get when no domains are found * fence_virt: don't report success for incorrect parameters * fence_virt: mcast: config: Warn when provided mcast addr is not used * fence-virt: Add vsock support * fence_virtd: Fix transposed arguments in startup message * fence_virtd: Cleanup: remove unused configuration options * fence_virtd: Implement hostlist for the cpg backend * fence_virtd: Cleanup config module * fence_virtd: cpg: Fail initialization if no hypervisor connections * fence_virtd: Make the libvirt backend survive libvirtd restarts * fence_virtd: Allow the cpg backend to survive libvirt failures * fence-virtd: Add cpg-virt backend plugin * fence_virtd: Remove checkpoint, replace it with a CPG only plugin * fence_virtd: Fix select logic in listener plugins * Document the fence_virtd -p command line flag * fence_virtd: Log an error when startup fails * Retry writes in the TCP, mcast, and serial listener plugins while sending a response to clients, on write issues. * Make the packet authentication code more resilient in the face of transient failures. * Disable the libvirt-qmf backend by default * Bump the versions of the libvirt and checkpoint plugins * fence-virtd: Enable TCP listener plugin by default * fence-virtd: Cleanup documentation of the TCP listener * fence_xvm/fence_virt: Add support for the validate-all status op * fence-virt: Add list-status command to man page and metadata * fence-virt: Log message to syslog in addition to stdout/stderr * fence-virt: Permit explicitly setting delay to 0 * fence-virt: Add 'list-status' operation for compat with other agents * Allow fence_virtd to run as non-root * Remove delay from the status, monitor and list functions * Resolves several problems in checkpoint plugin, making it functional. * Use event listener implementation from libvirt. * daemon_init: Removed PID check and update * fence-virt: client: Do not truncate VM domains in list output * client: fix "delay" parameter checking (copy-paste) * fence-virt: Fix broken restrictions on the port ranges * fence-virtd: Fix printing wrong system call in perror * fence-virtd: Allow multiple hypervisors for the libvirt backend * fence-virt: Fix small memory leak in the config module * fence-virt: Fix mismatched sizeof in memset call * fence-virt: Send complete hostlist info * fence-virt: Clarify the path option in serial mode * fence_virt/fence_xvm: Print status when invoked with -o status * fence-virt: Fix for missed libvirtd events * fence-virt: Fail properly if unable to bind the listener socket * Drop executable flag for man pages * fence_virtd: Return success if a domain exists but is already off. * fence_virt: Fix typo in fence_virt(8) man page * Improve fence_virt.conf man page description of 'hash' * Add a delay (-w) option. * Remove duplicated port struct entry * Add a TCP listener plugin for use with viosproxy * In serial mode, return failure if the other end closes the connection before we see SERIAL_MAGIC in the reply or timeout. * Update libvirt-qmf plugin and docs * Fix crash when we fail to read key file. * Fix erroneous man page XML * Add 'interface' directive to example.conf * Return proper error if we can't set up our socket. * Fix startup in systemd environments * Add systemd unit file and generation * Don't override user's pick for backend server module * Use libvirt as default in shipped config * Fix serial domain handling * Rename libvirt-qpid * Fix static analysis errors * Reword assignment to appease static analyzers * Add map_check on 'status' action * Don't reference out-of-scope temporary * Add libvirt-qmf support to the libvirt-qpid plugin * Convert libvirt-qpid plugin to QMFv2 * Fix incorrect return value on hash mismatch * Fix error getting status from libvirt-qpid plugin * Fix typo that broke multicast plugin * Make fence-virt requests endian clean * Fix input parsing to allow domain again * Provide 'domain' in metadata output for compatibility * High: Fix UUID lookups in checkpoint backend * Fix man page references: fence_virtd.conf and fence_virt.conf * Add 'list' operation for plugins; fix missing getopt line * Make configure.in actually disable plugins * Fix metadata output * Rename parameters to match other fencing agents * Fix fence_xvm man page to point to the right location * Return 2 for 'off' like other fencing agents * Reset flags before returning from connect_nb * Use nonblocking connect to vmchannel sockets * More parity with other fencing agents' parameters * Add basic daemon functions * Fix bug in path pruning support for serial plugin * Fix libvirt-qpid bugs found while testing * Fix segfault caused by invalid map pointer assignment * Add 'monitor' as an alias for 'status' * Add serial listener to configuration utility * Make serial/vmchannel module enabled by default * Add missing 'metadata' option to help text * Add metadata support to fence_xvm/fence_virt * Allow IPs to be members of groups * Allow use of static mappings w/ mcast listener * Enable VM Channel support in serial plugin * Mirror libvirt-qpid's settings in libvirt-qpid plugin * Enable a configurable host/port on libvirt-qpid plugin * Static map support and permissions reporting * Add capabilities to virt-serial * Note that serial support is experimental * Add vmchannel serial event interface * Add static map functions. * Better config query; multiple value/tag support * Add simple configuration mode * Add missing man pages * Allow setting config values to NULL to clear them * Sort plugins by type when printing them * Clean up some configuration plugin information * Hostlist functionality for libvirt, libvirt-qpid * Make fence_xvm compatibility mode enabled by default * Fix libvirt / mcast support for name_mode * Fix agent option parsing * Make uuids work with libvirt-qpid * Add 'help' to fence_virtd * Fix libvirt-qpid build * Make 'reboot' work * Initial checking of libvirt-qpid plugin * Make symlink/compatibilty mode disabled by default * Use immediate resolution of symbols * Use sysconfdir for /etc/fence_virt.conf * Fix package name and install locations * Make cluster mode plugin work * Enable 'on' operation for libvirt backend * Initial port to autoconf * Call generic history functions * Make history functions generic * Cleanups, add daemon support * Make all plugins dynamically loaded * Remove dummy serial prototypes * Make listeners plugins * Add name_mode to example.conf * Move VM naming scheme to top level of config * Add missing log.c, enable syslog wrapping * Drop duplicate fencing requests * Don't require specifying an interface in fence_virt.conf * Fix empty node parsing * Use the default port by default * Don't overwrite config files * Install modules, too * Add temporary 'make install' target * Make a default configuration file * Make mcast work with UUIDs * Add architecture overview description * Make multicast use config file * Integrate config file processing * Create server-side plugin architecture * Make libvirt a built-in plugin * serial: Make client work

  • Release Date
    Feb 23 2022
  • References
    Bugzilla: 1065966, 1185058
  • Type
    recommended
  • Severity
    moderate

cloud_download Downloads

SUSE Linux Enterprise Server for SAP Applications 12.3 x86_64
  • Packages
    fence-agents
    Fence Agents for High Availability
    4.9.0+git.1624456340.8d746be9-4.17.10 lock rpm lock src
SUSE Linux Enterprise Server for SAP Applications 12.3 ppc64le
  • Packages
    fence-agents
    Fence Agents for High Availability
    4.9.0+git.1624456340.8d746be9-4.17.10 lock rpm lock src
SUSE Linux Enterprise High Availability Extension 12.3 s390x
  • Packages
    fence-agents
    Fence Agents for High Availability
    4.9.0+git.1624456340.8d746be9-4.17.10 lock rpm lock src