shield
Recommended update for crmsh
SUSE-SLE-HA-12-SP3-2019-2301
This update for crmsh fixes the following issues: - Ensure that enable/disable actions via the command "crm maintenance" are committed automatically (bsc#1112593) - Prevent hb_report from infinite waiting on named pipe in /var/log/ (bsc#1121912) crmsh was updated to version 3.0.4: * Fix: bootstrap: "-i" option doesn't work (bsc#1103833, bsc#1103834) * high: bootstrap: Use default IP address for ring0 (bsc#1069142) * low: bootstrap: change multi-heartbeats as option-mode * low: bootstrap: Clarify messages * low: bootstrap: give a confirm message when remove node * low: bootstrap: Improve comments / error messages * low: bootstrap: Fall back to logging into $TMPDIR/ha-cluster-bootstrap.log * low: bootstrap: Check for firewalld before SuSEfirewall2 * medium: bootstrap: Add support for chrony * Detect firewall by checking installed packages * low: ui_cluster: complete node name once or the same node name will be completed many times with many "Tab"s * medium: enable add the second heartbeat line for unicast * medium: bootstrap: check init options before running * we can add other option checkings to here later * low: bootstrap: simplify the code for checking adminIP * low: bootstrap: reset dev value when input of dev not valid * low: bootstrap: catch OSError except instead of crash * low: bootstrap: give error hints when use sbd without watchdog * medium: enable add the second heartbeat line for mcast * medium: bootstrap: adminIP should not be exist before config * medium: bootstrap: adminIP should not be the network self * fix: utils.list_cluster_nodes: use "crm_node -l" first * medium: utils: list_cluster_nodes: read nodes list from cib.xml * medium: utils: extend "IP/Network" codes for IPv4/IPv6 both * low: ui_cluster: strip "None" when cmd stdout is None * medium: bootstrap: valid adminIP * medium: bootstrap: use strict regrex and valid function for bindnetaddr/mcastaddr * low: bootstrap: when node joining, it will take a while after init_cluster_local * low: bootstrap: join_csync2 may take a long while so, use status_long and status_done to give the hints * medium: bootstrap: configure with IPv6(unicast) * medium: bootstrap: configure with IPv6(mcast) * medium: bootstrap: disable completion and history when running bootstrap * low: ui_cluster: Add two new lines before add a new node * low: bootstrap: Don't rely on ha-cluster-* shortcuts * fix: bootstrap: remove cib.xml before corosync.add_node * low: bootstrap: color the input error message * medium: bootstrap: add callback function to check valid port range * high: cibconfig: Normalize - to _ in param names (bsc#1111579) * medium: ra: Handle obsoletes attribute (bsc#1111579) * Fix missing argument in RAInfo's constructor.
-
Release DateSep 5 2019
-
References
-
Typerecommended
-
Severitymoderate
cloud_download Downloads
SUSE Linux Enterprise High Availability Extension 12.3 s390x
-
Packagescrmsh
High Availability cluster command-line interfacecrmsh-scripts3.0.4-13.15.1lock rpmlock src
Crm Shell Cluster Scripts3.0.4-13.15.1lock rpm
SUSE Linux Enterprise Server for SAP Applications 12.3 ppc64le
-
Packagescrmsh
High Availability cluster command-line interfacecrmsh-scripts3.0.4-13.15.1lock rpmlock src
Crm Shell Cluster Scripts3.0.4-13.15.1lock rpm
SUSE Linux Enterprise Server for SAP Applications 12.3 x86_64
-
Packagescrmsh
High Availability cluster command-line interfacecrmsh-scripts3.0.4-13.15.1lock rpmlock src
Crm Shell Cluster Scripts3.0.4-13.15.1lock rpm